?>
Составить программу на Паскаль Найти корни уравнения ax2 + bx + c =0 (a<>0) при условии D>=0Составить программу и блок-схемуИмя программы КорниВывести на экран значения:Запрос: Введите переменныеВывод:Значение равноВывести два знака после запятой Только на школьном уровне ( написать нужно будет в тетрадь )
Ответы
Const
n=5;
Var
ma:array[1..n,1..n] of integer;
i,j,max,maxj,a:integer;
begin
max:=-1;
randomize;
writeln('Matrix:');
for i:=1 to n do
begin;
for j:=1 to n do
begin;
ma[i,j]:=random(10);
write(ma[i,j]:4);
end;
writeln;
end;
for j:=1 to n do
begin
for i:=1 to n do
a:=a+ma[i,j];
if a>max then
begin
max:=a;
maxj:=j;
end;
a:=0;
end;
write('Максимальный по сумме столбец:',maxj);
end.
Пример работы кода:
Matrix:
8 6 8 0 2
6 1 2 9 8
8 1 8 0 1
4 5 1 5 2
3 0 9 9 5
Максимальный по сумме столбец:1