purchase
?>

Задумано трехзначное число, у которого сумма крайних цифр равна средней. Напишите программу, которая выводит все такие числа. По окончании вывода программа должна вывести сколько чисел она вывела. (PYTHON)

Информатика

Ответы

uuks2012
Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write('Введите строку : ');
    readln(s);
    write('Введите слово : ');
    readln(a);
       if(pos(a, s) <> 0) then writeln('Слово "',a,'" в строке есть')
       else writeln('В строке такого слова нет');
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задумано трехзначное число, у которого сумма крайних цифр равна средней. Напишите программу, которая выводит все такие числа. По окончании вывода программа должна вывести сколько чисел она вывела. (PYTHON)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vovkiv7864
peresvetoff100015
kazan-ugoop36
langprint
DudukinSerega2507834
Valeria123864531
Aleksandrivanovna
elvini857
russstep
Dmitrievich1871
sdvigov
cardiodoc08
annakorolkova79
Горина
nailboxru