Ulianev77
?>

Написать программу Pascal, которая определяет, сколько человек из N кандидатов (количество кандидатов пользователь задаёт в начале программы) подходит для занятий в секцию баскотбола по его росту (если рост выше 180см, то подходит Для решения использовать цикл с заданным числом повторение

Информатика

Ответы

oniks-plus

Uses
  Crt;
Var
  i, N, kol: byte;
  sum_rost, sr_rost: real;
  team: array[1..100] of real;
Begin
  sum_rost := 0.0;
  sr_rost := 0.0;
  kol := 0;
  write('Введите количество членов команды');
  read(N);
  writeln('Введите рост каждого члена команды');
  for i := 1 to N do
    begin
      readln(team[i]);
      sum_rost := sum_rost + team[i];
    end;
  sr_rost := sum_rost / N;
  for i := 1 to N do
    if (team[i] > sr_rost) then
      kol := kol + 1;
  writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
  write(' равно ', kol);
End.

Я надеюсь надо было на паскале написать?)

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу Pascal, которая определяет, сколько человек из N кандидатов (количество кандидатов пользователь задаёт в начале программы) подходит для занятий в секцию баскотбола по его росту (если рост выше 180см, то подходит Для решения использовать цикл с заданным числом повторение
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bmashutav16
Попова1271
KovalenkoIL
aamer9992680
vetviptime
xarfagr
igor-790
katar050419735
Александрович Алексеевна
MN-Natusik80
ooottdi
Шеина
adhotel
Ахмедшина Трубников1249
andreevaanastsiyao82