whiskyandcola
?>

написать программу в pascal, которая выводит числа из диапазона от 72 до 134, удовлетворяющие условиям: 1. вывести все чётные числа; 2. вывести числа, оканчивающиеся на "3"; 3. вывести числа, сумма цифр которых меньше 11.

Информатика

Ответы

ti2107

Код программы:

var i, sum, a:integer;

begin

 writeln('Четные числа:');

 for i:= 72 to 134 do begin

   if i mod 2 = 0 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, оканчивающиеся на "3":');

 for i:= 72 to 134 do begin

   if i mod 10 = 3 then

     write(i, ' ');

 end;

 

 writeln();

 writeln();

 writeln('Числа, сумма цифр которых меньше 11:');

 for i:= 72 to 134 do begin

   a:= i;

   sum:= 0;

   while a <> 0 do begin

     sum := sum + a mod 10;

     a := a div 10;

   end;

   if sum < 11 then

     write(i, ' ');

 end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу в pascal, которая выводит числа из диапазона от 72 до 134, удовлетворяющие условиям: 1. вывести все чётные числа; 2. вывести числа, оканчивающиеся на "3"; 3. вывести числа, сумма цифр которых меньше 11.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bar02
Tkachenko1050
Sergei1198
dimoni86
Ekaterina1654
Николаевич1033
Avetisyan575
Рожнов
Андреевна-Арзуманян1109
Радецкая264
mail66
school24mir23
tretyakovamarina201155
kashxb2056
re22no22