tanysha1990
?>

найти ошибку почему оно не считывает сколько раз было введено число 4. Создать и законспектировать в тетрадь программу: пользователь вводит 8 чисел, определите, сколько раз он ввел число 4.

Информатика

Ответы

peregovorkacoffee

program z3;

var a,b,i:integer;

begin

b:=0;

writeln('Введите 8 чисел');

for i:=1 to 8 do

begin

readln(a);

if a = 4 then b:=b+1

end;

writeln('Число 4 было введено ',b, ' раз')

end.

Объяснение:

Цикл со счётчиком:

1) ввод числа

2) проверка условия если число равно 4, то переменную b увеличиваем на 1

Вывод b

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

найти ошибку почему оно не считывает сколько раз было введено число 4. Создать и законспектировать в тетрадь программу: пользователь вводит 8 чисел, определите, сколько раз он ввел число 4.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

smirnovaL1286
Mariya Filippov
Чубкова1290
yuraotradnov
myrisik2490
galkavik
Ioanova Korneeva1093
NIKOLAEVNA
Малыхин Валерьевна621
maglevanyycpt
Svetlaru70
Конычева-музей"260
Abdullaev
Yurok9872
Любовь