Vasileva
?>

Паскаль , через С Клавиатуры вводиться Границы промежутка - 2 числа (от 1 до 20 Написать программу, которая найдет сумму и произведение всех целых чисел промежутка включительно и вывода результат на экран program 1; var i, dobutok, suma :integer; begin dobutok:=1; suma:=0; for i:=1 to 20 do begin dobutok:=dobutok*i; suma:=suma+i; end; write('dobutok = ', dobutok, ' , suma = ', suma); end. Как сделать чтоб в этой программе границы вводились С КЛАВИАТУРЫ?

Информатика

Ответы

sharaeva-is
#include <iostream> // Заголовочный файлusing namespace std; // пространство имен, надо для ввода и вывода информации
int main() // Главная функция
{ int A[10], k = 0,i,n=10; // объявление переменных
// Заполняем вручную элементы массива
A[0] = 1;
A[1] = 2;
A[2] = 3;
A[3] = 4;
A[4] = 5;
A[5] = 6;
A[6] = 7;
A[7] = 8;
A[8] = 11;
A[9] = 10;
for(i=0;i<n;i++) // цикл от 0 до n
{
if((A[i] %3==0) && (A[i]%4!=0)) k++; // Условие, Если элементы массива А делятся на 3 с остатком 0 И элементы массива не делятся на 4 с остатком 0, то считаем количество.}
cout << "Количество чисел, которые делятся нацело на 3 и не делятся на 4: " << k<< endl;
system("pause"); // Нужно для паузы в программы, для просмотра результата.
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль , через С Клавиатуры вводиться Границы промежутка - 2 числа (от 1 до 20 Написать программу, которая найдет сумму и произведение всех целых чисел промежутка включительно и вывода результат на экран program 1; var i, dobutok, suma :integer; begin dobutok:=1; suma:=0; for i:=1 to 20 do begin dobutok:=dobutok*i; suma:=suma+i; end; write('dobutok = ', dobutok, ' , suma = ', suma); end. Как сделать чтоб в этой программе границы вводились С КЛАВИАТУРЫ?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevgenevna
Mbkozlov6
Акимцева27
ASRodichev
verkop9
kisuhakisa
notka19746
Сергеевич1386
Sergei1805
uvarovig
mail5
Shevtsov1818
lider-mpl550
jaksonj326
verkop9