Поделитесь своими знаниями, ответьте на вопрос:
В магазине продаётся сыр стоимостью 45 рублей/кг и икра стоимостью 70 рублей за 100 гамм. Написать программу, рассчитывающую стоимость покупки. Количество каждого товара ввести с клавиатуры.В Visual basic
Объяснение:
#include <iostream>
using namespace std;
int main()
{
int N, average, sum = 0, counter = 0;
cout << "Введите размер массива (N): ";
cin >> N;
int A[N];
cout << "Вводите значения массива: " << endl;
for (int i = 0; i < N; ++i){
cin >> A[N];
sum += A[N];
}
average = sum / N;
cout << "Среднее арифметическое: " << average << endl;
for (int i = 0; i < N; ++i){
if(A[i] < average){
counter++;
}
}
cout << "Кол-во элементов: " << counter << endl;
return 0;
}