alekseymedvedev1981
?>

Составьте программу вычислений значения функции по формуле у=5/2х+7 на языке программирования

Информатика

Ответы

oniks-plus
// PascalABC.NET 3.2, сборка 1436 от 01.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadlnInteger('Количество строк: ');
  var a:=new string[n];
  for var i:=0 to n-1 do a[i]:=ReadlnString;
  Writeln('*** РЕЗУЛЬТАТ ***');
  a:=a.Select(s->(s,s.ToCharArray.Where(c->c=' ').Count))
    .OrderBy(vk->vk[1]).Select(vk->vk[0]).ToArray;
  a.Println(NewLine)
end.

Пример
Количество строк:  4
Это   первая   стро  ка
А     это    вторая       строка
Это- третья
    Четвертая - последняя
*** РЕЗУЛЬТАТ ***
Это- третья
    Четвертая - последняя
Это   первая   стро  ка
А     это    вторая       строка

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу вычислений значения функции по формуле у=5/2х+7 на языке программирования
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

missimeri
kagurkina
sergeychelyshev197618
Герасимова107
zdv686857
mikhisakov2017
Less2014
svetrusval
sanseth5
Иванов
Васильевич Валерьевна
vitalis79
armsam76
smakarov76
naratnikova
▲