lighturist
?>

Даны два натуральных числа. Напишите программу, которая определяет, в каком из них: а) больше цифр. б) сумма цифр больше НАПИШИТЕ ЕЩЁ ПРОГРАММУ, через 40 мин папа придёт и мне тогда будет кирдик, если я не сделаю​

Информатика

Ответы

lor005148

Ниже

Объяснение:

def numberSum(n):

   d = 0

   k = 0

   while n:

     d = n% 10

     n/=10

     k = k + d

   return k

def charSum(n):

   counter = 0

   while n:

       n /= 10

       counter+=1

   return counter

a = int(input())

b = int(input())

if numberSum(a) > numberSum(b):

   print("Сумма чисел больше в a")

elif numberSum(a) == numberSum(b):

   print("Сума цифр равна")

else:

   print("Сумма чисел больше в b")

if charSum(a) > charSum(b):

   print("Символов больше в a")

elif charSum(a) == charSum(b):

   print("Количество символов равно")

else:

   print("Символов больше в b")

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два натуральных числа. Напишите программу, которая определяет, в каком из них: а) больше цифр. б) сумма цифр больше НАПИШИТЕ ЕЩЁ ПРОГРАММУ, через 40 мин папа придёт и мне тогда будет кирдик, если я не сделаю​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

schernov
alenih13
ВостриковаСтародубцева1980
Stefanidi_Semeikina1896
YuRII1236
timonina29
Vladimirovna1370
andrey4work918
Шиловский126
tatiana2676
airlineskozlova69
delfinmos
ermisyareg436
sedalex
sergeystepanov231