?>
Условие Дано натуральное число n. Необходимо поменять порядок цифр числа на обратный. Формат входных данных В программу вводится одно целое число n (1≤n<109 Формат выходных данных Программа должна вывести число n после обработки. входные данные 123 12 выходные данные 321 21
Ответы
#include <iostream>
using namespace std;
int main()
{
int reverse_digit, start_num;
cout << "Input a number: " << endl;
cin >> start_num;
if ((start_num < 1) || (start_num > 109))
{
cout << "a number is not should of range!" << endl;
return 0;
}
cout << "Reverse number: ";
while(start_num != 0)
{
reverse_digit = start_num % 10;
start_num /= 10;
cout << reverse_digit;
}
cout << endl;
return 0;
}