ikosheleva215
?>

Что такое «вложенное условие»?2. Как записывается условие в условном операторе?3. Составить программу на ЯП. Требуется перевести пятибалльную оценку в ее наименование: 5 — «отлично», 4 — «хорошо», 3 — «удовлетворительно», 2 — «неудовлетворительно».​

Информатика

Ответы

Викторович
Const n=15;
var i,k,mn,indm,sm: integer;
    a: array[1..n] of integer;
    sar: real;
begin
  randomize;
  writeln('исходный массив:');
  mn:=n; sm:=0;
  k:=1;
  for i:=1 to n do
  begin
    a[i]:=random(-n,n);
    sm:=sm+a[i];
    write(a[i],' ');
    if a[i]=mn then k:=k+1;    
    if a[i]<mn then
    begin
      mn:=a[i];
      indm:=i;
      k:=1;
    end;
  end;
  writeln;
  writeln('минимальный элемент: ',mn,'  индекс: ',indm);
  sm:=sm-a[indm]*k;  
  writeln('сумма элементов без минимального: ',sm);
  sar:=sm/(n-k);
  writeln('среднее арифметическое: ',sar:7:3);
end.

исходный массив:
-1 6 -12 -14 14 -14 10 -9 -2 -6 9 -1 -13 13 -2 
минимальный элемент: -14  индекс: 4
сумма элементов без минимального: 6
среднее арифметическое:   0.462

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Что такое «вложенное условие»?2. Как записывается условие в условном операторе?3. Составить программу на ЯП. Требуется перевести пятибалльную оценку в ее наименование: 5 — «отлично», 4 — «хорошо», 3 — «удовлетворительно», 2 — «неудовлетворительно».​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

viktorovna_Imamaevich679
makscska22879
janetp
Dmitrii sergei463
Designer
obitelsvel8
efimov33
palmhold578
Kalashnikova
kulagin777
Kalmikova1666
minaskorolev8
Taurus59707
Александра-Андрей909
martinson