ValeriyaAleksandr
?>

Путешествуя на автомобиле, вы заехали на заправку. До следующей заправки 200 километров. Напишите программу, которая будет определять, нужно ли вам заправляться или можно подождать до следующей станции. Программа должна спрашивать: • Какой размер вашего бензобака в литрах? • Сколько горючего в бензобаке (в процентах)? • Сколько километров проходит автомобиль на одном литре? Результат работы программы должен выглядеть примерно так: Размер бензобака: 60. Размер бензобака: 60 Заполненная в процентах: 40 заполнена в процентах: 30 Км на 1 литре: 10 Км на 1 литре: 10 "Вы можете проехать еще 240 км, Вы можете проехать еще 144 км Следующая заправочная через 200 км. Следующая заправка через 200 км. Можно подождать следующей заправки заправьтесь СЕЙЧАС Дополнительное задание: Добавьте к программе погрешность в 5 литров на случай не совсем точных показаний расхода топлива.

Информатика

Ответы

Pavel1545
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var m,n:integer;
  Write('Количество строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var p:=ReadInteger('Введите число Р:');
  var b:array of integer;
  SetLength(b,4*m);
  var k:=0;
  for var i:=n-p to n-1 do
    for var j:=0 to m-1 do
      if a[i,j] mod 4=0 then begin
        b[k]:=a[i,j]; Inc(k)
        end;
  SetLength(b,k);
  b.Print
end.

Тестовое решение:
Количество строк и столбцов матрицы: 6 8
67 70 68 72 38 72 96 38
49 75 24 55 72 63 21 40
72 12 60 22 74 30 13 45
22 45 39 24 35 97 64 31
76 62 15 94 56 28 31 13
41 67 75 37 67 13 25 20
Введите число Р: 4
72 12 60 24 64 76 56 28 20

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Путешествуя на автомобиле, вы заехали на заправку. До следующей заправки 200 километров. Напишите программу, которая будет определять, нужно ли вам заправляться или можно подождать до следующей станции. Программа должна спрашивать: • Какой размер вашего бензобака в литрах? • Сколько горючего в бензобаке (в процентах)? • Сколько километров проходит автомобиль на одном литре? Результат работы программы должен выглядеть примерно так: Размер бензобака: 60. Размер бензобака: 60 Заполненная в процентах: 40 заполнена в процентах: 30 Км на 1 литре: 10 Км на 1 литре: 10 "Вы можете проехать еще 240 км, Вы можете проехать еще 144 км Следующая заправочная через 200 км. Следующая заправка через 200 км. Можно подождать следующей заправки заправьтесь СЕЙЧАС Дополнительное задание: Добавьте к программе погрешность в 5 литров на случай не совсем точных показаний расхода топлива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tihonovrv477
Nikolaevna1623
Svetlana1877
ОвчинниковаТатьяна
s-shulga
Yuliya Aleksandr686
praktikadok
shutovaa3471
Радецкая264
miyulcha8077
manager9
waspmoto6188
axo-geo
eugene869154
stairov536