olgamalochinska
?>

Написать программу на паскале, которая определяет, есть ли среди цифр натурального числа n цифра k.

Информатика

Ответы

fedorenkoroman

program NK;

var

K, N: integer;

begin

write('Число N: ');

readln(N);

write('Цифра К: ');

readln(K);

while (N <> 0) do

begin

if ((N mod 10) = K) then

begin

writeln('Есть');

halt;

end;

N := N div 10;

end;

writeln('Нет');

readln;

end.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале, которая определяет, есть ли среди цифр натурального числа n цифра k.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arsen-ai-ti
Larisa-Andrei
gav973
macmakka
prianik6
MikhailovnaAnastasiya
akopovarch
А Дзукаев1562
Chutaeva381
Grishanin
Палкина-Дроздова
gutauta6
Шапкина1531
Volochaev
sanhimki47