самир1078
?>

PYTON Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Информатика

Ответы

kurlasku

Решение в лоб:

x = int(input())

lucky = x % 10

check = False

x //= 10

while x > 0:

   if x % 10 == lucky:

       check = True

       break

   else:

       lucky = x % 10

   x //= 10

if check == False:

   print("Одинаковых цифр,стоящих рядом нет!")

else:

   print("Есть одинаковые цифры, стоящие рядом!")

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTON Напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Александровна1244
apetrov13
msk27
lika080489
edelstar83
Golovinskii_Sirotkina1944
Нина1449
Georgievich-Zamudinovna2003
pryvalovo48
oldprince840
pechatlogo4
Sergei1198
Reginahappy
Стародубцева_Васильевич485
oslopovavera