var x:integer;
begin
readln(x);
if (x mod 3=0) then
x := x + 1
else
x := x - 2;
writeln(x);
end.
Объяснение:
Если я верно понял задачу, то решение выше.
Вводим число, если оно кратно 3 - прибавляем 1, если нет - вычту 2.
После вывожу результат.
Поделитесь своими знаниями, ответьте на вопрос:
Информатика Составить программу которая определяет если число кратно трём, то это увеличиваем на 1, иначе уменьшаем на 2.
var x:integer;
begin
readln(x);
if (x mod 3=0) then
x := x + 1
else
x := x - 2;
writeln(x);
end.
Объяснение:
Если я верно понял задачу, то решение выше.
Вводим число, если оно кратно 3 - прибавляем 1, если нет - вычту 2.
После вывожу результат.