Aleksei368
?>

Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиатуры.

Информатика

Ответы

denblacky

program a1;

Var

a,b,c,max,min:integer;

Begin

Readln(a,b,c);

if (a = b) or (a = c) or (b = c) or ((a = b) and (b = c)) then

writeln('Ошибка, числа должны быть разными');

if (a>b) and (a>c) then max:=a;

if (b>a) and (b>c) then max:=b;

if (c>a) and (c>b) then max:=c;

if (a<b) and (a<c) then min:=a;

if (b<a) and (b<c) then min:=b;

if (c<a) and (c<b) then min:=c;

Writeln('Max:', max, ' Min:', min);

write('Среднее арифметическое:',(a+b+c)/3);

end.


Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиа

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Радецкая264
Yekaterina358
fta1309
fokolimp
Bordo
buhh20104519
shneider1969
Drugov_Vladimirovna
shumeikoElena362
zbellatriks
asviridova07194
Korobeinikov-Yulich23
st-op767840
horina12
aleksey7800