Ivan1568
?>

Язык Pascal. Напишите программу, которая позволяет вводить координаты двух точек на плоскости. (координаты целочисленые) и выводит на экран расстояние между ними.

Информатика

Ответы

arbat

program  z1;

var xa,ya,xb,yb:integer;

begin

write('Введите координаты первой точки: ');

read(xa,ya);

writeln('Введите координаты второй точки: ');

read(xb,yb);

writeln('Расстояние между точками равно: ',sqrt(sqr(xb-xa)+sqr(yb-ya)):0:3);

end.

Объяснение:

Расстояние между двумя точками A(xa, ya) и B(xb, yb) на плоскости:

AB = \sqrt{(xb - xa)^{2} + (yb - ya)^{2}}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Pascal. Напишите программу, которая позволяет вводить координаты двух точек на плоскости. (координаты целочисленые) и выводит на экран расстояние между ними.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maksimovskiy7657
Герасимова107
kazimov832
starabanov
Elenabolt77
gardenkafe
Коробкова1437
ekaterinasamoylova4705
magazintrofey
dianakryukova00
Yurevich1344
Roman343247
Тамара_Григорьевна897
juli19657
sn009
▲