Khiryanov
?>

Написать программу (на языке Си), которая находит все двузначные числа, для которых сумма цифр входящих в число плюс квадрат суммы этих же цифр равна самому числу.

Информатика

Ответы

vanvangog199826

#include <stdio.h>

#include <math.h>

int main(){

   for (int i = 10; i< 100;i++)    

       if ((pow(i%10+i/10,2) + i%10 + i/10) == i)

           printf("%d\n",i);

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу (на языке Си), которая находит все двузначные числа, для которых сумма цифр входящих в число плюс квадрат суммы этих же цифр равна самому числу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tokarevaiv
Zimin1111
stertumasova29
Сергеевич1396
Maksim Dmitrii1579
Владимирович111
alina Korneev
turoverova5
Lyudmila-Popova
Tochkamail370
VladimirBorisovich
delonghisochi
lion13
ver2bit
olegmgu1