alyans29
?>

нужно очень На языке Паскаль Напишите программу наименьшего общего кратного следующих четырех чисел: 36, 54, 18 и 15, используя процедуру вычисления наибольшего общего делителя двух чисел.Если можно, то с объяснением

Информатика

Ответы

yliana

// НОД(a,b)*НОК(a,b)=a*b

procedure nod(x,y: integer; var n: integer);

begin

    repeat

        if x>y then x:=x mod y

        else y:=y mod x;

    until (x=0)or(y=0);

n:=x+y;

end;

var a,b,c,d,e,n: integer;

begin

readln(a,b,c,d);

nod(a,b,n);

e:=a*b div n;

nod(c,e,n);

e:=c*e div n;

nod(d,e,n);

Writeln('НОК = ',d*e div n);

end.

Объяснение:

Пример:

36 54 18 15

НОК = 540

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно очень На языке Паскаль Напишите программу наименьшего общего кратного следующих четырех чисел: 36, 54, 18 и 15, используя процедуру вычисления наибольшего общего делителя двух чисел.Если можно, то с объяснением
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Эвелина
Seropyan-Elena1944
afilippov3321
ruslan
denbelousov963
AOS2015
Lebedeva1577
sergey
Эвелина
Елена-Семенова
aistenok-28
karien87
zanthia94
morozov1605
ирина Альбертовна