#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "russian");
int n, a=0, b=1;
cin >> n;
while (n > 0)
a += n % 10;
b *= n % 10;
n = n / 10;
}
cout << "Сумма цифр равна:" << a << "\nПроизведение цифр равно:" << b;
Поделитесь своими знаниями, ответьте на вопрос:
на С++ написать программу, которая выводит заданное число на экран, а также сумму и произведение его цифр.
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "russian");
int n, a=0, b=1;
cin >> n;
while (n > 0)
{
a += n % 10;
b *= n % 10;
n = n / 10;
}
cout << "Сумма цифр равна:" << a << "\nПроизведение цифр равно:" << b;
}