katekn6032
?>

Сформируйте массив, содержащий 15 элементов, с датчика случайных чисел. Получите новыймассив, каждый элемент которого равен сумме соответ-ствующего исходного элемента и его квадрата. В полу-ченном массиве найдите максимальный элемент и егоНомер. Выведите на экран исходные и полученные ре-зультаты. с++​

Информатика

Ответы

Николаевич
Матрица не может быть прямоугольной так иначе будет не понятно что подразумевается под диагональю
#include<iostream>
#include<vector>
int main() {
int n;
std::cin>>n;
std::vector<std::vector<int>> matrix(n);
for (int i =0;i<n;++i) {
    for (int j =0;j<n;++j) {
        int elem;
        std::cin>>elem;
        matrix[j].push_back(elem);
    }
}
int first_diag = 0;
int second_diag = 0;
for (int i = 0;i<n;++i) {
    first_diag+=matrix[i][i];
    second_diag += matrix[i][n-i-1];
}
int res = 0;
res = first_diag - second_diag;
std::cout<<res;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сформируйте массив, содержащий 15 элементов, с датчика случайных чисел. Получите новыймассив, каждый элемент которого равен сумме соответ-ствующего исходного элемента и его квадрата. В полу-ченном массиве найдите максимальный элемент и егоНомер. Выведите на экран исходные и полученные ре-зультаты. с++​
Ваше имя (никнейм)*
Email*
Комментарий*