Suralevartem
?>

Составить алгоритм вычисления периметра прямоугольного треугольника, если известны его катеты. В ПРОГРАММЕ С++

Информатика

Ответы

Пимкина Сергеевич

while True:

   sentence = input('Введите предложение: ')

   if sentence.count(' ')>=2: break

   print('Предложение должно содержать как минимум три слова')

length = 0

for symbol in sentence:

   if not symbol in [',',' ','/','.','!','&','?','-']:

       length+=1

if length > 10: print('Хорошо')

else: print('Не хорошо')

print(length)

Чуть поэлегантнее:

while True:

   sentence = input('Введите предложение: ')

   if sentence.count(' ')>=2: break

   print('Предложение должно содержать как минимум три слова')

length = sum(not symbol in [',',' ','/','.','!','&','?','-'] for symbol in sentence)

if length > 10: print('Хорошо')

else: print('Не хорошо')

print(length)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить алгоритм вычисления периметра прямоугольного треугольника, если известны его катеты. В ПРОГРАММЕ С++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stepan Rastorgueva850
Александровна1685
ladykalmikova81
Bezzubova_Stepanov1355
smartschoolfili6
milaudina
marver201040
zloshop9
tatyanaryzhkova
spz03
oxy03214428
izumrud153
stic1995
Новицкий1107
Milovidova