Paradismebel
?>

Массив A заполнили, а потом изменили. Pascal: n := 100; for i := 1 to n do A[i] := i; for i := 1 to n div 2 do A[i] := A[n + 1 - i]; Python: n = 100 a = [] for i in range(0, n): a.append(i + 1) for i in range(0, n // 2): a[i] = a[n - 1 - i] Чему равна сумма первого и последнего элементов полученного в итоге массива?

Информатика

Ответы

VladimirovnaViktorovich

n = 100

a = []

for i in range(0, n):

 a.append(i + 1)

for i in range(0, n // 2):

 a[i] = a[n - 1 - i]

print(a[0], a[len(a)-1])

Первый элемент равен 100.

Последний элемент также равен 100.

Их сумма соответственно равна 200.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Массив A заполнили, а потом изменили. Pascal: n := 100; for i := 1 to n do A[i] := i; for i := 1 to n div 2 do A[i] := A[n + 1 - i]; Python: n = 100 a = [] for i in range(0, n): a.append(i + 1) for i in range(0, n // 2): a[i] = a[n - 1 - i] Чему равна сумма первого и последнего элементов полученного в итоге массива?
Ваше имя (никнейм)*
Email*
Комментарий*