Владимирович_Ралина
?>

Язык Pascal . Напишите программу, которая позволяет вводить с клавиатуры натуральное 3- значное число N и выполняет с ним следующие операции:a) выводит на экран его цифры - по одной на каждой строкеb) формирует число N1, образованное перестановкой цифр исходного числа вобратном порядке, например, из числа 123 должно получиться число 321, с) формирует число N2, полученное перестановкой цифр десятков и единицd) формирует число N3, полученное перестановкой цифр сотен и десятков, е) формирует число N4, полученное приписыванием цифры единиц в качествецифры тысяч (например, число 137 должно преобразоваться в 7137), f) формирует число N5, полученное приписыванием цифры единиц в качествецифры тысяч и цифры сотен в качестве единиц (например, 137 должнопреобразоваться в 71371) Все пункты задания 3 должны быть реализованы в одной программе.​

Информатика

Ответы

saltikovaK.S.1482

program z1;

var n,c,d,e,n1,n2,n3,n4,n5:integer;

begin

write('n (99<n<1000) = ');

readln(n);

c:=n div 100;

d:=n div 10 mod 10;

e:=n mod 10;

writeln(c);

writeln(d);

writeln(e);

n1:=e*100+d*10+c;

writeln(n1);

n2:=c*100+e*10+d;

writeln(n2);

n3:=d*100+c*10+e;

writeln(n3);

n4:=e*1000+n;

writeln(n4);

n5:=e*10000+n*10+c;

writeln(n5)

end.

Объяснение:

Вводим число

Разбиваем на отдельные цифры сотен (1 цифра), десятков (2 цифра) и единиц (3 цифра)

Выводим на экран и формируем числа согласно условиям и примерам

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Pascal . Напишите программу, которая позволяет вводить с клавиатуры натуральное 3- значное число N и выполняет с ним следующие операции:a) выводит на экран его цифры - по одной на каждой строкеb) формирует число N1, образованное перестановкой цифр исходного числа вобратном порядке, например, из числа 123 должно получиться число 321, с) формирует число N2, полученное перестановкой цифр десятков и единицd) формирует число N3, полученное перестановкой цифр сотен и десятков, е) формирует число N4, полученное приписыванием цифры единиц в качествецифры тысяч (например, число 137 должно преобразоваться в 7137), f) формирует число N5, полученное приписыванием цифры единиц в качествецифры тысяч и цифры сотен в качестве единиц (например, 137 должнопреобразоваться в 71371) Все пункты задания 3 должны быть реализованы в одной программе.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fox-cab3444
bsi771184
ikhilovb76
Koshovkina1721
Павловна897
gip5362
vera4
alexderru
Нозадзе_Новиков392
Alnkseevna
damir
Boykoyelena
lorsam36
predatorfishing608
taanaami75