program zz1;
var a, b, c, d, e, sum, pr:integer; //задаем переменные целого типа
begin
write(' введите первое число '); // вводим с клавиатуры первое число
read(a);
write(' введите второе число '); // вводим с клавиатуры второе число
read(b);
write(' введите третье число '); // вводим с клавиатуры третье число
read(c);
write(' введите четвертое число '); // вводим с клавиатуры четвертое число
read(d);
write(' введите пятое число '); // вводим с клавиатуры пятое число
read(e);
sum:=a + b + c + d + e;
pr:= a * b * c * d * e;
writeln(' сумма = ', sum); // выводим ответ
write(' произведение = ', pr);
end.м
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая будет считать сумму пяти произвольных чисел, введенных пользователем. Для ввода чисел использовать одну переменную. (Паскаль)
program zz1;
var a, b, c, d, e, sum, pr:integer; //задаем переменные целого типа
begin
write(' введите первое число '); // вводим с клавиатуры первое число
read(a);
write(' введите второе число '); // вводим с клавиатуры второе число
read(b);
write(' введите третье число '); // вводим с клавиатуры третье число
read(c);
write(' введите четвертое число '); // вводим с клавиатуры четвертое число
read(d);
write(' введите пятое число '); // вводим с клавиатуры пятое число
read(e);
sum:=a + b + c + d + e;
pr:= a * b * c * d * e;
writeln(' сумма = ', sum); // выводим ответ
write(' произведение = ', pr);
end.м
Объяснение: