kotocafe45
?>

Составить блок-схемы для решения задач и написать программу У гусей и кроликов вместе 64 лапы. Сколько могло быть кроликов и гусей (указать все сочетания, которые возможны)?

Информатика

Ответы

Матфеопуло1006

using System;


class Program

{

private static int GetThird(int num)

{

var result = 0;

var kv = num * num;

if (num % 2 == 0)

{

for (var i = num / 2; i > 0; i--)

{

result += kv - i * 2 + 1;

}

for (var i = 0; i < num / 2; i++)

{

result += kv + i * 2 + 1;

}

}

else

{

for (var i = (num - 1) / 2; i > 0; i--)

{

result += kv - i * 2;

}

result += kv;

for (var i = 0; i < (num - 1) / 2; i++)

{

result += kv + i * 2 + 2;

}

}

return result;

}


//оптимизированное свое решение, коротко и ясно

private static int GetThirdOptimized(int num)

{

var result = 0;

var kv = num * num - num + 1;


for (var i = 0; i < num; i++)

{

result += kv + i * 2;

}


return result;

}


private static void Main()

{

Console.WriteLine("Введите натуральноe числo ");

var i = int.Parse(Console.ReadLine());

Console.WriteLine("{0}^3 = {1} = {2} = {3}", i, i * i * i, GetThird(i), GetThirdOptimized(i));

Console.Read();

}

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить блок-схемы для решения задач и написать программу У гусей и кроликов вместе 64 лапы. Сколько могло быть кроликов и гусей (указать все сочетания, которые возможны)?
Ваше имя (никнейм)*
Email*
Комментарий*