gigbes
?>

Задан двумерный массив А из 4-х строк и 4-х столбцов. Составить программу, которая подсчитывает произведение элементов массива, лежащих вне главной диагонали на c++

Информатика

Ответы

Wlad967857
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10

// PascalABC.NET 3.0,сборка 1076
begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходная последовательность');
  a.Println;
  Writeln('Сумма элементов: ',a.Sum);
  Write('Кол-во четных, кратных пяти: ');
  Writeln(a.Where(x-> x mod 10 = 0).Count)
end.

Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан двумерный массив А из 4-х строк и 4-х столбцов. Составить программу, которая подсчитывает произведение элементов массива, лежащих вне главной диагонали на c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

inna-zub
annashersheva
Nzharenikova
Yevgenevich
losevev5619
Суханова1532
Sergeevich-irina
generallor3
Илья_Ветклиники1655
Два в какой степени будет число 16777216
PushkinaKurnosov984
kot271104
steger
Mark-Petrovich
Elen-ti81459
timsch12