?>
С++ Дан массив из 10 элементов. Вывести на экран девятый элемент. Точность чисел - 2 знака после запятой. Формат входных данных Вводятся 10 вещественных числел ai, не превосходящих 1000 по абсолютной величине и имеющих не более двух знаков после запятой, — элементы массива. Формат выходных данных Вывести на экран девятый элемент. входные данные 1.01 2.02 3.03 4.04 5.05 6.06 7.07 8.08 9.09 10.10 выходные данные 9.09
Ответы
const
n = 10; //количество элементов массива
var
a: array [1..n] of real;
i: integer;
begin
for i:= 1 to n do
begin
writeln('Введите ', i, ' элемент массива');
readln(a[i]); //вводим очередной элемент массива
end;
write('Исходный массив: ');
for i:= 1 to n do
write(a[i], ' '); //Выводим исходный массив
writeln; //Перевод на новую строку
write('Полученный массив: ');
for i:= 1 to n do
begin
a[i]:= a[i] * a[n]; //элемент массива умножаем на последний элемент
write(a[i], ' '); //выводим полученный элемент массива
end;
end.