ribcage52
?>

4. Напишите программу, которая выведет на экран всенатуральные числа от 1 до 1000, кратные 3.​

Информатика

Ответы

Pastushenkoen
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите три числа:');
  if b.Between(a,c) then (a,b,c):=(2*a,2*b,2*c);
  if (a<0) or (b<0) or (c<0) then (a,b,c):=(Abs(a),Abs(b),Abs(c));
  Writeln('a=',a,', b=',b,', c=',c)
end.

Пример
Введите три числа: 3.6 -5.2 8
a=3.6, b=5.2, c=8

Первый оператор читает с клавиатуры три вещественных числа и помещает их в переменные a,b,c.
Второй оператор проверяет, находится ли второе число (b) между остальными двумя (может и совпадать с одним из них). Если да, то значение каждой переменной удваивается.
Третий оператор проверяет, есть ли среди введенных чисел хоть одно отрицательное. Если есть, значения заменяются их модулями (становятся положительными).
И в конце следует вывод результатов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

4. Напишите программу, которая выведет на экран всенатуральные числа от 1 до 1000, кратные 3.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

brakebox
kuchino09
Jannadon77
Бирюков Карпова1379
evrotrastop64
Aleksandr_Vasilev
Feyruz90
retropluse832
cernovarmechta
zakaz
best00
ValeriyaAleksandr
bugaevnicky
olgalooo
echervyakov