var a, b, c: real;
begin
readln(a, b, c);
if (a<0) then
a:=(power (a,2));
if (b<0) then
b:=(power(b,2));
if (c<0) then
c:=(power(c,2));
writeln(a, ' ', b, ' ', c);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Даны три действительных числа возвести в квадрат те из них, значения которых отрицательны. неотрицательные оставить без изменения(Pascal)напишите программу
var a, b, c: real;
begin
readln(a, b, c);
if (a<0) then
a:=(power (a,2));
if (b<0) then
b:=(power(b,2));
if (c<0) then
c:=(power(c,2));
writeln(a, ' ', b, ' ', c);
end.