Поделитесь своими знаниями, ответьте на вопрос:
Определите значение переменных a, b, с после ввода значений с клавиатуры программа: var a, b, c: real; begin readln (a); readln (b, c); end. Ввод значений с клавиатуры: 5 enter 2.3 0.47entr В Лазарусе написал так: program Project1; var a, b, c: real; begin readln (a); readln(b, c); end. Выдает ошибку, не хочет считать, помечает рыжим вторую строку, что делать?
program Program1;
var i, j, n, k: integer;
var result: real;
var array1: array [1..255] of real;
begin
result := 0;
write('Введите значение N (не более 255): ');
readln(n);
for i := 1 to n do
begin
write('Введите значение ', i, ' элемента массива: ');
readln(array1[i]);
end;
begin
writeln('Массив, размером - ', n, ' элементов(а):');
for i := 1 to n do write(array1[i], ' ');
writeln;
end;
for i:=1 to n do
begin
k := 0;
for j:=1 to n do
if array1[i] = array1[j] then k := k + 1;
if k = 1 then result := result + array1[i];
end;
writeln('Сумма уникальных элементов массива = ', result);
end.