isinyakin
?>

Составьте программу  вычисления значения функции y=x3 –x2 +16x-43 для х, меняющего в диапазоне            от 4 до -4 шагом 0, 5.2)Составьте программу, печатающую все простые числа, не превосходящие заданное число.​

Информатика

Ответы

kashihina

python

1)

from numpy import arange # нужно установить библиотеку numpy

for x in arange(4, -4, -0.5):

   print('x =', str(x) + ' :', x * 3 - x * 2 + 16 * x - 43)

2)

number = int(input('Введите число: '))

primeNumbers = []

for i in range(1, number + 1):

   numberDividers = 0

   for z in range(1, i + 1):

       if i / z == i // z:

           numberDividers += 1

   

   if numberDividers == 2:

      primeNumbers.append(i)

if len(primeNumbers) == 0:

   print('Нет простых чисел до числа ' + str(number))

else:

   print('Простые числа:')

   for i in primeNumbers:

       print(i)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу  вычисления значения функции y=x3 –x2 +16x-43 для х, меняющего в диапазоне            от 4 до -4 шагом 0, 5.2)Составьте программу, печатающую все простые числа, не превосходящие заданное число.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tboychenko
Stepan Rastorgueva850
ЕленаАнастасия315
sedalex
mg4954531175
agutty3
ГармаеваЕкатерина1637
Сколько ячеек содержит диапазон b3: c6
aleksey270593
Vladimir1172
juliaipatova1739
AleksandraRuslan504
zatoichi69
Александрович Алексеевна
vis-lyubov8832
EVLAMPIN56
▲