svetlanadianowa
?>

Написать программу на С# Пользователь вводит с клавиатуры целое шестизначное число. Написать программу, которая определяет, является ли введенное число – счастливым (Счастливым считается шестизначное число, у которого сумма первых 3 цифр равна сумме вторых трех цифр

Информатика

Ответы

cometa94558

Const n=10;

m=15;

Var A :Array[1..n,1..m] of integer;

i: 1..n; //индекс (номер) строки

j: 1..m; //индекс (номер) столбца

count: byte;

Begin

<Инициализация (формирование) массива…>;

<Вывод сформированного массива>;

for j:=1 to m do // для столбца с номером j

begin

count:=0 // до проверки столбца количество искомых элементов равно нулю

for i:=1 to n do

begin

if A[i,j] mod 2 =0 then count:=count+1 // обработка элемента i в столбце j

end; // цикла по i

writeln(′В столбце ′,j, ′четных элементов - ′, count); //вывод результатов обработки столбца j

end; // цикла по i

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на С# Пользователь вводит с клавиатуры целое шестизначное число. Написать программу, которая определяет, является ли введенное число – счастливым (Счастливым считается шестизначное число, у которого сумма первых 3 цифр равна сумме вторых трех цифр
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vallzh8328
corneewa20096
olgolegovnak
missimeri
Ryadovboxing23
slavutich-plus2
morozova4956
Ruslan374
ivanlimeexpo
Donat-Evgeniya793
klimovala2
Yurii537
ajsklan
veraplucnika
anchutk3016
▲