ananyananar
?>

Напишите программу, которая в последовательности натуральных чисел отделяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчиваюшееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - сумму чисел, оканчивающихся на 4. Программа должна быть на паскале! Очень

Информатика

Ответы

Алиференко_Елена342

var n,i,a,min: integer;

begin

readln(n);

min := 30001;

for i := 1 to n do

begin

readln(a);

if (a mod 10 = 4) and (a < min)

then min := a;

end;

writeln(min)

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в последовательности натуральных чисел отделяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчиваюшееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - сумму чисел, оканчивающихся на 4. Программа должна быть на паскале! Очень
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вакуленко
T91610933073266
nebo2020
barnkim
corneewa20096
zakaz1
Evagg3856
tatianaavoronina66
LesnovaVeronika1830
aaltuxova16
ooo-krasa
Larisa-Andrei
s-laplandia6
AnzhelikaSlabii1705
OOO&quot;Kiprei&quot;_Aleksandr1938