Ainura Pokhomova
?>

Дан массив A из N целых чисел. Вычислите и выведите сумму первого и последнего числа, второго и предпоследнего и т.д. - всего N/2 сумм. Input Со стандартного устройства ввода в первой строке вводится целое чётное число N (2 <= N <= 1000) —количество элементов массива. Во второй строке через пробел вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000 Output Выведите N/2 требуемых сумм. Выводить пробел в конце строки не нужно. Sample Input 6 3 2 5 2 8 5 Sample Output 8 10 7 На языке С

Информатика

Ответы

Tatarnikova1507

Проходим по строке, запоминая текущий символ и сколько раз он уже повторился. Если следующий символ такой же, то просто увеличиваем длину серии на 1, если нет - выводим информацию про серию и начинаем новую. Надо не забыть корректно обработать последний символ - после него серия также заканчивается.

Код (Python 3):

s = input()

current_digit, count = None, 0

for digit in s:

   if current_digit != digit:

       if count > 0:

           print(count, current_digit)

       current_digit, count = digit, 1

   else:

       count += 1

print(count, current_digit)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив A из N целых чисел. Вычислите и выведите сумму первого и последнего числа, второго и предпоследнего и т.д. - всего N/2 сумм. Input Со стандартного устройства ввода в первой строке вводится целое чётное число N (2 <= N <= 1000) —количество элементов массива. Во второй строке через пробел вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000 Output Выведите N/2 требуемых сумм. Выводить пробел в конце строки не нужно. Sample Input 6 3 2 5 2 8 5 Sample Output 8 10 7 На языке С
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Жуков219
rashodnikoff
svetarakityanskaya
elena-kondyreva
familumid
marver201040
abramovae
Косоногов Иосифовна
evamining
Fruktova Gazaryan
evavard
Ионов202
o-lala88387
keti0290103
dovgash2