almihanika435
?>

ЧЕМ СМОЖЕТЕ ХОТЯ БЫ, У МЕНЯ СКОРО КОНЧАТСЯ Составьте программу на Python k = (5 (5c-8))/(2c+2) Напишите в гуг ле repl.it, и выберите Python, там и надо создавать программу

Информатика

Ответы

anazarov80

using namespace std;

#include <algorithm>

#include <iostream>

#include <vector>

#include <ctime>

int main() {

vector<int> arr;

srand(time(0));

int N = 10;

int min = 9999999, minIndex;

int average = 0;

for(int i = 1; i<=N; ++i) {

 arr.push_back(rand());

 cout << arr[i-1] << " ";

 if(arr[i-1]<min) {

  min = arr[i-1];

  minIndex = i-1;

 }

 average+=arr[i-1];

}

cout << endl << "Min: " << min << endl << "Average: " << average/N << endl;

swap(arr[minIndex], arr[arr.size()-1]);

for(int i = 1; i<=N; ++i) {

 cout << arr[i-1] << " ";

}

cout << endl << " > average: ";

for(int i = 1; i<=N; ++i) {

 if(arr[i-1]>average/N) {

  cout << arr[i-1] << " ";

 }

}

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ЧЕМ СМОЖЕТЕ ХОТЯ БЫ, У МЕНЯ СКОРО КОНЧАТСЯ Составьте программу на Python k = (5 (5c-8))/(2c+2) Напишите в гуг ле repl.it, и выберите Python, там и надо создавать программу
Ваше имя (никнейм)*
Email*
Комментарий*