?>
С целью пригласить своих одноклассников на чтение художественной литературы создайте проект «100 замечательных книг», в котором должны быть два массива из названий прочитанных вами 10 книг и из их года изданий. Составив план выполнения проекта по нижеследующим условиям, представьте его и напишите программу, упорядочите названия книг по алфавиту.
Ответы
#include<cstdlib>
#include<locale>
#include<ctime>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int min_value, max_value;
int mas[10];
// инициализируем массив случайными числами
for(int i=0; i<10; i++) mas[i] = rand()%100;
//находим минимальное значение
min_value = mas[0];
for(int i=0; i<10; i++)
if(min_value > mas[i]) min_value = mas[i];
cout << "Минимально значение: " << min_value << '\n';
//находим максимальное значение
max_value = mas[0];
for(int i=0; i<10; i++)
if(max_value < mas[i]) max_value = mas[i];
cout << "Максимальное значение: " << max_value << '\n';
//выводим среднее значение максимального и минимального значение
cout << "Среднее значение: " << (double) (min_value+max_value)/2 << '\n';
}