?>
Напишите программу на Pascal(с использованием цикла while) Пользователь вводит целые числа в цикле (разные: четные, нечетные, положительные, отрицательные в любом порядке и количестве Считайте и выведите на экран значения первых трех отрицательных нечетных чисел. После чего завершите цикл.
Ответы
program proga;
var str: array of string;
readstr: string; i, x, err, count: integer;
necheti: array [1..3] of integer; y: boolean;
begin
y := false;
while y = false do begin;
Readln(readstr);
str := readstr.Split(' ');
for i := 1 to Length(str) do begin
Val(str[i - 1], x, err); if (x mod 2 <> 0) and (x < 0) then begin count += 1; if count = 1 then necheti[1] := x; if count = 2 then necheti[2] := x; if count = 3 then necheti[3] := x;
if count = 3 then begin Writeln('1: ', necheti[1]);
Writeln('2: ', necheti[2]);
Writeln('3: ', necheti[3]); y := true; end;
end;
end;
end;
end.
Объяснение:
Вводить значения строго через пробел и без запятых