arturo95
?>

Напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1], а[3]... и т.д. Если количество элементов нечётное, то последнее число должно оставаться на месте питон ​

Информатика

Ответы

master-lamaster

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(' '.join([str(i) for i in a])

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1], а[3]... и т.д. Если количество элементов нечётное, то последнее число должно оставаться на месте питон ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artemy682719
katrin50
doorhan42n6868
Elenazhukovafashion7
ktripoleva294
info36
Ермакова Ирина674
Александровна-Васильевна
Напишите программу в Паскаль:
Федор_Рауф1592
Popova838
navi35374
Pochkun-Oleg
kristina
Климова1317
ВадимСмирнов116
▲