Поделитесь своими знаниями, ответьте на вопрос:
В бригаде, работающей на уборке сена, имеется N сенокосилок. Первая сенокосилка работала m часов, а каждая следующая на 10 минут больше, чем предыдущая. Напишите программу, которая считает сколько времени проработала вся бригада? Примечание: одновременно бригада может использовать только одну сенокосилку. Формат входных данных: На входе программа принимает два числа: количество сенокосилок и количество часов работы 1 сенокосилки. Формат выходных данных: На экран выводится время отработанное всей бригадой по формату: HH ч MM мин. Sample Input: 5 2 Sample Output: 11 ч 40 мин нужно решить через do while(C++)
ответ: Программа рабочая, проверена.
Program zadacha;
var
a: array [1..50] of integer; // размерность массива = 50
i,k: integer;
begin
begin
for i:=1 to 50 do
a[i] := Random(100); // числа от 0 до 100 будут присутствовать в массиве
writeln('Заполненный массив: ');
for i:=1 to 50 do
write(a[i],' '); end; // выводим массив на экран до проверки
writeln; //новая строка
writeln('Введите значение числа K: '); readln(k);
writeln('Элементы массива, кратные K:');
for i:=1 to 50 do
if (a[i] mod k = 0) then write(a[i],' ');
end.
Объяснение:
i - порядковый номер элемента
a - сам массив
k - вводимое число
В остальном оставила комментарии.
Размерность массива и его диапазон указан в программе числами, т.к. в задаче не было вопроса о вводе элементов или вводе размерности.