VladimirovnaKashintsev1151
?>

Написать программу на языке С++, при case В некотором учебном заведении действуют следующие правила приема. Абитуриенты сдают три экзамена. Если они набирают не менее то это дает право поступить на дневное отделение, от 10 до 12 — вечернее, от 8 до 9 — заочное и ниже — отказ в приеме на учебу. Написать программу, которая в зависимости от суммы набранных сообщает абитуриенту его права на поступление.

Информатика

Ответы

ksankaaleks611

Python

from random import randint

n=int(input('Введите количество элементов массива : '))

if n%2!=0:

 n=n+1

a=[0]*n

for i in range (0, n):

 a[i]=randint(1,100)

 

print(a)

i=0

k=0

# сортируем первую часть массива по возрастанию

while i< n//2-1:

 if a[i]>a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=-1

 i +=1

# сортируем вторую часть массива по убыванию

while i < n-1:

 if a[i]<a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=n//2-1

 i +=1

 

print(a)  


массив содержит чёткое количество элементов напишите программу которая сортирует первую половину мас

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке С++, при case В некотором учебном заведении действуют следующие правила приема. Абитуриенты сдают три экзамена. Если они набирают не менее то это дает право поступить на дневное отделение, от 10 до 12 — вечернее, от 8 до 9 — заочное и ниже — отказ в приеме на учебу. Написать программу, которая в зависимости от суммы набранных сообщает абитуриенту его права на поступление.
Ваше имя (никнейм)*
Email*
Комментарий*