?>
Машина поста: На ленте располагается группа меток, отдалённых друг от друга пустыми секциями. Написать программу, которая сожмёт метки таким образом, чтобы самая правая из них осталась на месте. Исходное положение не имеет значения (Выберите самостоятельно), количество меток может быть любым.
Ответы
uses GraphABC;
procedure OutLightGreen(n:integer);
begin
var OldColor:=FontColor;
SetFontColor(clLightGreen);
Write(n:5);
SetFontColor(OldColor)
end;
begin
var a:=MatrixRandom(10,14,-180,320);
var m:=ReadInteger('n=');
Writeln;
SetFontColor(clWhite);
Font.Style:=fsBold; Font.Name:='Courier';
Brush.Color:=clBlack; Window.Clear(clBlack);
var k:=0;
for var i:=0 to 9 do begin
for var j:=0 to 13 do
if a[i,j]>m then begin
Inc(k); OutLightGreen(a[i,j]) end
else Write(a[i,j]:5);
Writeln
end;
SetFontColor(clRed);
Writeln('Количество элементов равно ',k)
end.