dumpler
?>

2. Прочитайте условия задач и напишите программный код. і. Дан массив , состоящая из чисел, разделенных пробелами. Определите, сколько в нейЧисел.іі. Дан массив, в которой цифра 5 встречается несколько раз. Определите общееколичество цифр 5 в массиве.​

Информатика

Ответы

spikahome
#include "stdafx.h"
#include <iostream>
#include <string>
using namespace std;

string cod(char* text,int ROT) { 
for (int i = 0; i < strlen(text); i++)
if (text[i] != ' ')
 text[i] += ROT;
return text; 
};

string decod(char* text, int ROT) { 
for (int i = 0; i < strlen(text); i++)
if (text[i] != ' ')
 text[i] -= ROT;
return text; 
};

int main() {
setlocale(LC_ALL, "Rus");
cout << "Введите текст: " << endl;
char s[256]; cin.getline(s,255);
cout << "Что нужно сделать(1-декод. 2-код.): " << endl;
int d; cin >> d;
cout << "ROT:" << endl;
int ROT; cin >> ROT;

if (d == 2) cout<< cod(s, ROT)<< endl;
else cout<< decod(s, ROT)<< endl;
system("pause");
}

Пример(1):
Введите текст:
Proverka
Что нужно сделать(1-декод. 2-код.):
2
ROT:
3
Suryhund

Пример(2):
Введите текст:
Suryhund
Что нужно сделать(1-декод. 2-код.):
1
ROT:
3
Proverka

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2. Прочитайте условия задач и напишите программный код. і. Дан массив , состоящая из чисел, разделенных пробелами. Определите, сколько в нейЧисел.іі. Дан массив, в которой цифра 5 встречается несколько раз. Определите общееколичество цифр 5 в массиве.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vitalevna1186
lilit-yan
Никита_Тузов
pashyanaram
hotel-info
skryabinamaria
Vladimirovna
ShafetdinovAndrei
kogakinoa
marinarodina90
Mariya987
Nefedova1432
anton
katya860531
Sergeevich-irina