?>
Привет с задачами по ассемблеру. 1) Даны два числа X и Y; X = 15, Y = 3. Написать программу вычисления Z=X+Y. Записать результат в десятичной системе счисления.2) Написать программу вычисления на ассемблере выражения: e/b+a-d*c ; где a = 3, b = 2, c = 3, e = 30, d = 4Желателен подробный ответ .
Ответы
x: real;
begin
x := 1;
while (cos(1 / tan(x)) >= 0) do x := x + 1;
Write(x, ': ', cos(1 / tan(x)))
end.
Результат выполнения программы:
6: -0.956871790478342
Если нужна промежуточная печать:
var
x: real;
begin
x := 1;
while (cos(1 / tan(x)) >= 0) do begin
Writeln(x, ': ', cos(1 / tan(x)));
x := x + 1
end;
Writeln(x, ': ', cos(1 / tan(x)))
end.
Результат выполнения программы:
1: 0.800844301895226
2: 0.897089962539917
3: 0.743794228654611
4: 0.64963571596558
5: 0.956565479264333
6: -0.956871790478342