cimora-kativ
?>

Быстрее! программирование на pythonтема: работа со списками у вас есть персонаж, рядом способностей и статов. напишите программу по заданным условиям: 1. персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. каждая стата имеет свой запас. № 92значения запасов каждой статы должны быть случайны  –  в пределах от 60 до 80 и быть представлены в списке stats = []: stats = [] attributes = 5 for i in range(attributes): r = random.randint(60, 80) stats.append(r)2. в начале игры пользователю предоставляется возможность однократно повысить одну стату на случайное количество единиц  –  от 5 до 15: select = int(input('select: ')) select -= 1 stats[select] = stats[select] + random.randint(5, 15) обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на случайное значение в пределах от 5 до 15: for i in range(len(stats)): if i == select: continue stats[i] = stats[i] - random.randint(5, 153. персонаж обладает набором скилов: fireball, lightning, silence, fire ward.использование каждого из них отнимает разное количество единиц статов, а именно: атрибуты / способностиstrength dexterityintelli- gencewisdom charismafireball 12 15 28 10 5lightning 7 13 15 30 10silence 23 10 12 7 18fire ward 20 23 14 6 17занесите эти данные в список, чтобы в дальнейшем воспользоваться ими в игре: fireball = [12, 15, 28, 10, 5] № 944. предоставьте пользователю возможность использовать скилы, например, по нажатию f применяется fireball, l  –  lightning и т. д. после применения какой-либо из способностей, запас статов будет уменьшаться, согласно выше таблице. рассмотрим следующий пример: 1. было stats: 70 64 63 80 65. 2. применили fireball: 12 15 28 10 5. 3. стало stats: 58 49 35 70 60. следите за тем, чтобы элементы в списке stats = [] не стали отрицательными. результат работы: файл с расширением .py. выбор по на ваше усмотрение: atom, pycharm, python idle или др.

Информатика

Ответы

symkifm
Вопрос №1:   1) - г                       2) - а                       3) - б                       4) - д                       5) - в вопрос №2: 1) - б                       2) - в                       3) - а                       4) - д                       5) - г вопрос №3: в,г вопрос №4: для ответа на этот вопрос необходимы картинки из условия, так что ответить без них не представляется возможным. вопрос №5: в вопрос №6: д вопрос №7: 1) - г                       2) - в                       3) - а                       4) - д                       5) - б вопрос №8: 1) - б                       2) - а                       3) - в вопрос №9: здесь,как и в вопросе №4 решающую роль играет рисунок,которого нет - ответа без него быть не может. вопрос №10: а,б,д вопрос №11: в -  информационные компьютерные технологии с одновременным использованием нескольких видов информации.вопрос №12: все 3 варианта ответа имеют место быть верными, то есть все варианты верны.
pbttehnology
Сказано было сформировать массивы с имененем а и  в. заполняем их  целыми числами, так что и   объявить массивы можно как целые. но это мелочи, не обязательные. var      a, b: array[1..20]of integer;       i, s,n: integer;       begin        writeln('массив а: ');     randomize;             for i : = 1 to 20 do            begin            a[i] : = random(100) - 50;       write(a[i],' ');             if (a[i] > 0) and (i mod 2 = 0)  then          begin        n: =n+1;             b[n]: = a[i];                   s : = s + b[n] * b[n];           end;       end;     writeln();     writeln('массив в: ');     for i: =1 to n do write(b[n]);     writeln;     writeln('s = ', s); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Быстрее! программирование на pythonтема: работа со списками у вас есть персонаж, рядом способностей и статов. напишите программу по заданным условиям: 1. персонаж имеет набор статов: strength, dexterity, intelligence, wisdom, charisma. каждая стата имеет свой запас. № 92значения запасов каждой статы должны быть случайны  –  в пределах от 60 до 80 и быть представлены в списке stats = []: stats = [] attributes = 5 for i in range(attributes): r = random.randint(60, 80) stats.append(r)2. в начале игры пользователю предоставляется возможность однократно повысить одну стату на случайное количество единиц  –  от 5 до 15: select = int(input('select: ')) select -= 1 stats[select] = stats[select] + random.randint(5, 15) обратите внимание, что повышая одну стату на сгенерированное число, все остальные должны уменьшиться на случайное значение в пределах от 5 до 15: for i in range(len(stats)): if i == select: continue stats[i] = stats[i] - random.randint(5, 153. персонаж обладает набором скилов: fireball, lightning, silence, fire ward.использование каждого из них отнимает разное количество единиц статов, а именно: атрибуты / способностиstrength dexterityintelli- gencewisdom charismafireball 12 15 28 10 5lightning 7 13 15 30 10silence 23 10 12 7 18fire ward 20 23 14 6 17занесите эти данные в список, чтобы в дальнейшем воспользоваться ими в игре: fireball = [12, 15, 28, 10, 5] № 944. предоставьте пользователю возможность использовать скилы, например, по нажатию f применяется fireball, l  –  lightning и т. д. после применения какой-либо из способностей, запас статов будет уменьшаться, согласно выше таблице. рассмотрим следующий пример: 1. было stats: 70 64 63 80 65. 2. применили fireball: 12 15 28 10 5. 3. стало stats: 58 49 35 70 60. следите за тем, чтобы элементы в списке stats = [] не стали отрицательными. результат работы: файл с расширением .py. выбор по на ваше усмотрение: atom, pycharm, python idle или др.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lika080489
Probitbiz6
is0019
Narine natalya
dobrovolsky-tmz1
Anatolii
snk7777202
makovei78
Kulikov1065
Юлия1689
Kochereva-Sergei
shabunina17
leeka152522
Наталья
M10M11M12