Задание 1
program HelloMoney;
var
y, i: integer; // Объявим переменные для количества лет вклада и для счетчика цикла
p, s: real; //Объявим переменные для количества процентов и величины вклада
begin
write('Какая сумма вклада? ');
readln(s); // Указываем сколько составляет вклад
write('На сколько лет вклад? ');
readln(y); // Указываем на сколько лет вклад
write('Какая процентная ставка?');
readln(p); // Указываем процентную ставку
for i:=1 to y do
s := s + s*p/100; // Прибавляем к вкладу ежегодный процент
write('Сумма денег составит: ', s);
end.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу выводящую таблицу умножения с заданным первым и вторым числом от 1 до 9.
Задание 1
program HelloMoney;
var
y, i: integer; // Объявим переменные для количества лет вклада и для счетчика цикла
p, s: real; //Объявим переменные для количества процентов и величины вклада
begin
write('Какая сумма вклада? ');
readln(s); // Указываем сколько составляет вклад
write('На сколько лет вклад? ');
readln(y); // Указываем на сколько лет вклад
write('Какая процентная ставка?');
readln(p); // Указываем процентную ставку
for i:=1 to y do
s := s + s*p/100; // Прибавляем к вкладу ежегодный процент
write('Сумма денег составит: ', s);
end.
Объяснение: