?>
1. Опишите термин «Одномерный массив». Приведите пример [2] 2. Прочитайте условия задач и напишите программный код. Дана строка, состоящая из слов, разделенных пробелами. Определите длину строки. [2] 3. Дан список чисел. Определите, сколько в этом списке элементов, которые больше двух своих соседей, и выводите количество таких элементов. Крайние элементы списка никогда не учитываются, поскольку у них недостаточно соседей. [2] 4. Дан список целых чисел, число к и значение С. Необходимо вставить на позицию С индексом к элемент, равный С, сдвинув все элементы, имевшие индекс не менее к, вправо. [2]
Ответы
begin
var a:=ArrRandom(30,1960,2016); a.Println;
var iFirst:=a.IndexMin;
var iLast:=iFirst;
var vMin:=a[iFirst];
for var i:=29 downto iFirst+1 do
if a[i]=vMin then begin iLast:=i; break end;
if iLast=iFirst
then Writeln('Самый старший человек номер ',iFirst+1)
else Writeln('Первый из самых старших людей имеет номер ',
iFirst+1,', последний из людей этого возраста - номер ',
iLast+1)
end.
Тестовое решение
1987 1971 1974 1989 1989 1960 1987 2016 1992 1962 1971 2011 1993 1962 2008 1994 1994 1976 1988 2014 2011 1960 1971 2000 1973 2010 1964 1976 1971 1993
Первый из самых старших людей имеет номер 6, последний из людей этого возраста - номер 22