gub191025
?>

Напишите программу найти значение y, если х - вещественное число. y=-5+3x, если х> 0, либо y=x2-2, в противном случае.

Информатика

Ответы

alyonazharikowa4

var x,y: integer;

begin

readln (x);

if x> 0 then y=-5+3*x else

y=2*x-2

writeln (x);

end.

написал примерно, но должно работать.

Nonstop788848

паскаль.

 

немного не понятно: от 1 до 10   это относится только к нечетным числам или ко всем? ну напишу программу которая просто все числа вычисляет, если сама не сможешь поставить условие ограничения, то сообщи точное условие и напиши мне в личку

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv: integer;

begin

for i: =1 to 10 do begin

    writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

for i: =1 to 10 do begin

                              if a[i] mod 2=0 then summa: =summa+a[i] else

                                                        proizv: =proizv*a[i];

                          end;

writeln(summa,'   ',proizv); readln;

end.

Matveevanastya0170

паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv: integer;

begin

for i: =1 to 10 do begin

    writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

for i: =1 to 10 do begin

                              if a[i] mod 2=0 then summa: =summa+a[i] else

                                if (a[i]< =10) and (a[i]> =1) then   proizv: =proizv*a[i];

                          end;

writeln(summa,'   ',proizv); readln;

end.

 

жирным - это то, что я добавил)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу найти значение y, если х - вещественное число. y=-5+3x, если х> 0, либо y=x2-2, в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

smokestylemos
Дмитрий1974
evge-borisova2
ann-perminova2008
lazaren-ko
Yurevna_Kharkchinov1302
staskamolbio5152
Альберт Татьяна
dg9792794674
МАМОНОВА-андрей
SaraevaTretyakov1941
Nikita
magazintrofey
Алена
Низамов
▲