?>
Составить программу «Больничный лист». Питон. Программа запрашивает: фамилию сотрудника, среднедневной заработок, трудовой стаж. Выводит на экран: фамилию сотрудника, размер начисления за день по больничному листу. Размер начислений при стаже до 3-х лет 50%, от 3-х до 5-ти - 60%, от 5-ти до 8 - 80%, >8 - 100%.
Ответы
uses StrUtils;
var text,buffer : String;
var tpos,lastpos,counter,biggest : Integer;
begin
tpos := 0;
text := '';
while(tpos = 0) do begin
readln(buffer);
text += buffer;
tpos := pos('.',buffer)
end;
lastpos := 1;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
biggest := tpos-1; lastpos := tpos+1;
while(not (tpos = 0)) do begin
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
if (tpos-lastpos) > biggest then
biggest := tpos-lastpos;
lastpos := tpos+1;
end;
lastpos := 1; counter := 0;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
while(not (tpos = 0)) do begin
if (tpos-lastpos) = biggest then
counter += 1;
lastpos := tpos + 1;
tpos := PosEx(' ',text,lastpos);
if tpos = 0 then
tpos := PosEx('.',text,lastpos);
end;
writeln(counter);
end.