Задание 1: написать программу, которая по заданному значению аргумента x, вычислит значение функции y. Задание 2: составить таблицы значений функции y = f(x) на участке [0; 7] с шагом для x=1. Решение реализовать через все виды циклов.
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016 begin var n:=5; var z:=MatrixRandom(n,n,10,99); for var i:=0 to n-1 do begin for var j:=0 to n-1 do Print(z[i,j]); Writeln end; var imin:=0; var jmin:=n-1; for var i:=1 to n-1 do if z[i,n-i-1]<z[imin,jmin] then begin imin:=i; jmin:=n-i-1 end; Writeln('Zmin=Z[',imin+1,',',jmin+1,']=',z[imin,jmin]) end.
begin
var n:=5;
var z:=MatrixRandom(n,n,10,99);
for var i:=0 to n-1 do begin
for var j:=0 to n-1 do Print(z[i,j]);
Writeln
end;
var imin:=0;
var jmin:=n-1;
for var i:=1 to n-1 do
if z[i,n-i-1]<z[imin,jmin] then begin
imin:=i; jmin:=n-i-1
end;
Writeln('Zmin=Z[',imin+1,',',jmin+1,']=',z[imin,jmin])
end.
Тестовое решение:
26 62 62 90 76
21 67 69 43 37
18 19 35 88 91
60 91 87 46 27
49 71 16 77 81
Zmin=Z[3,3]=35
Замечание:
В массиве элементы нумеруются от 0 до 4, а при выводе номера индексов указаны для нумерации от 1 до 5 (так привычнее смотрится).